JarCheck 1.4

Check a Java jar to make sure all the javac -target versions of the class files are what you expect. Java application. Requires Java version 1.5 or later. All Java source code is included. to use: java -jar jarcheck.jar jartotocheck.jar 1.1 1.

JarCheck 1.4

Check a Java jar to make sure all the javac -target versions of the class files are what you expect. Java application. Requires Java version 1.5 or later. All Java source code is included. to use: java -jar jarcheck.jar jartotocheck.jar 1.1 1.7 where jartocheck.jar is the name of jar to check. It will check all the class files in it. In this example: 1.1 is the lowest acceptable target version number. 1.4 is the highest acceptable target version number. Currently, only version numbers 1.0, 1.1, 1.2, 1.3, 1.4, 1.5 and 1.6 are supported. The program does not currently test minor version numbers. Why would you use this utility? To make sure that a jar intended to run under an old 1.1 JVM contains no classes accidentally compiled with javac -target 1.5. Passing this test does not guarantee the jar will work on an old JVM. The jar still might use methods not bundled with old JVMs. This should catch however, classes normally compiled with target 1.1 that were accidentally compiled with 1.5 as a side effect of compiling some 1.5 class. There is a similar program called JarLook available at mindprod.com/products1.html#JARLOOK
Requirements: Java 1.6+

   



Top Software

New Software

Latest Reviews